Registration is not allowing Credit Card entry

My issue is similar to the topic below but none of the solutions worked.

The is the error I get.

   GET net::ERR_ABORTED 403 (Forbidden)
1 Like

Check your file permissions. You might need to change it using your ftp client or via SSH. Is everything else in your wordpress installation working properly? Do a “Wordpress Health Check” just in case.

I am having this problem suddenly on my site.

I have not changed anything on the site in forever!

I wonder if there is a general fix for this, as it seems to just pop up out of nowhere.

Any help appreciated.

If you’re using cloudflare you must turn Rocket Loader OFF or it won’t work.

thanks for getting back to me.
I’m not using cloud flare,
is it possible that there is an issue with the ssl,
I have just noticed that my ssl status says revoked!
I don’t know why that is,
but I wonder if that causes an issue.
thanks again.

If your SSL certificate is expired it’s likely causing issues with your site and you need to fix that.

Hi thanks again,

Its a funny thing,
the cert was revoked,
but my ssl is still payed for!

I am wondering if it is a response to the hack last week.
I think they may have revoked it for some reason.

I will get back to you if the response is interesting from godaddy!
maybe some othere s2members are having the same issue after that hack!


No idea, but that sounds good, always nice to have the full information since visitors might find your results helpful.

You need to check with them. I didn’t hear about this specific hack, but if that’s the case, it makes sense. They likely have a method for you to get a new certificate to replace the existing one manually somehow.

I like using Cloudflare because they handle those things in a more seamless manner and their certificates are free. It only breaks loopback, but the rest is all good.

Hi Guys,

I managed to get the ssl certificate for my site back up and running, Godaddy revoked it a few weeks ago after their server hack.

Anyway I thought that was causing the issue on my stripe form.
but no such luck.
the credit card field is still not allowing any input into the card number field.
you can check it out here.

I really am at a loss here,
I am running Divi from elegant themes, all up to date.
and honestly everything was working perfectly until recently.

Pleeeeaseee help me!

thanks again!

I use PayPal so I’m not familiar with Stripe forms. But just a quick observation, when I look at the page source, there is no input box there to click into. It just has a comment that says “A Stripe Element will be inserted here”. That can’t be right, can it? On my PayPal form, there’s an actual input box to click into and enter the card number.

Thanks for looking,

I have tried everything that I know here and to no avail.

I wonder if you guys can take a look and see what could be going on.


Have you tried a different theme or disabling your other plugins to see if the form suddenly works again? Was there a recent update to your theme or to a plugin? It seems unlikely that the issue is directly related to s2Member.

I will try that and get back to you,
thanks again,

My Health checker only shows that my PHP should be updated to a newer version that is currently not available by my provider (7.3.30 to 7.4)

And a scheduled event failed. It did not indicate how to fix.

So I have tried everything to get stripe working correctly!

got new ssl,
got godaddy to run tests,
changed theme, twice!
disabled all plugins apart from s2member.
build new page,
got rid of widgets,
test test test,

no luck.
any other ideas please!

thanks in advance,

still getting that strange code,

where the credit card input box should be??

Hi again,
I wonder if you have any other ideas on what might be going on here.?

I have checked with godaddy, updated ssl and its working fine,
I have checked with elegent themes,
I switched to another theme and the issue is the same no matter what.

I disabled all plugins,
still the same issue,

I checked and rechecked the api keys for stripe and saved them again,
no use.

The funny thing is,
I tried a paypal pro form and it is allowing credit card entries onto that form.

As far as I can figure out,
S2member is stopping credit card detail entry on the stripe form for some reason.

Please help,
thanks again,

You have both forms on one site? Impossible. Either or.

Just testing to see if the paypal form allowed you to type in credit card details,
I dont actually use paypal form usually.
stripe does not allow it,
paypal does.

heres a test page.
would be greatfull for your thoughts.


You’re getting this error…Failed to load resource: s2member-o.php:1 the server responded with a status of 403 ()

Not sure why this the case, but this is a permissions error.