Registration is not allowing Credit Card entry

FYI , I have the same issue and am eager for a solution. S2 Member STRIPE payments worked for 4 years and sudenly stopped allowing credit card entry in October 2021.

I am using Godaddy too.

Yes, I just noted that. It could be an issue with the certificate, but I doubt it. You may want to check and see if the permissions settings on your s2member folder were changed. This may be a shared issue since you both are on GoDaddy. They may have changed permission settings on certain folders. Can you check your permissions settings for the s2member folder and the file, s2member-o.php? That file is under wp-content > plugins > s2member.

Thanks for the insight,
I am going to try that now!
this has been a mission!

Will report back!

ok this is what I see,
under permissions it gives the value 0604.

what happens next?
thanks again.

Here is the permissions that are checked.

can you see anything wrong here?

Alright! I think we’re on to something. Try changing the permissions on the files in s2member to 0644. The permissions for the folders - you can try 0755.

Thanks Matt, I’m going to need a little guidence on how to do that. I am familure with the prinicple but not the execution. So, I am not a complete idiot as a benchmark for providing guidence which would be much appreciated.

You can reach out to your host or you can change the permissions for these files by going through cpanel and then file manager. If your host allows it, you can simply click on the numbers beside the folder and change the permissions number. I definitely think this is the issue. You had mentioned a hack - perhaps GoDaddy changed file and folder permissions to isolate it or to stop it - but I’m not sure why they were changed.

I made the changes but still have the same problems.

What are the file permissions on the s2member folders one step back - in the plugins folder? Are they set to 0755 or are they still 0604?

  1. Also was I also supposed to change all of the subfolders and files in the S2member path?

Ok,
so I managed to change the permissions on the php files on the txt files to 0644 in that subfolder.
no change to the problem yet.

All the folders have the permission 0705
and everything else seems to have 0604

should I change every folder to the 0755 permission?
I am a little apprehensive when Im in this deep!

It’s worth a shot. It looks as though something is blocking s2member loading correctly. Not just the php files but also the css and JavaScript. You could see if GoDaddy could help. Since you’re both on GoDaddy and your permissions are different from standard i would say there may be a connection there.

Hi there. No worries. You can always change the permissions back. Just trying some things since seeing the 403.

Thanks for your help on this,
it is great that you guys are willing to chip in when needed.
I owe you a beer at Christmas!

I have now logged another ticket with godaddy explaining all that we have found out on this thread.

So with the help of Almighty GOD we can get to the bottom of this!

I will get back to you soon with the results!

Blessings to you all guys,
enda.

The problem is GoDaddy. And it’s recurring since years. Get proper hosting.
Likely they use some caching or whatever. Lots of incompetent users draw measures to create unusable hosting.

If you don’t need lots of SSD space, just get a small cloud space and do it yourself. Or go for reliable specialised for WordPress hosting

Godaddy did not find a problem with the privleges and recommended that I reinstall S2member. Do you see a problem with that? Will I need to complete the S2 setup or will it remember the settings?