Stripe Credit Card Field not taking any entries

Hello, for some reason our stripe field stopped allowing people to type in it. Any ideas?
Help! I cant find the error!
https://incommunion.org/join-the-opf-get-involved/full-opf-membership/
S xoxox

Works fine on Firefox / Windows10. Check the browser / OS that it is failing on. Known issue with Safari / IOS.

Hi,
I just realized I have the same issue (on Firefox, Chrome and Microsoft Edge on my laptop as well as Chrome on Android)…did you manage to fix your issue, and if so, was this some plugin/theme conflict?

I disabled all plugins except for the S2Member Framework (and the Pro), and EZPHP (which allows for PHP code to be recognized), but to no avail…

Works fine for me, but is everyone who’s experiencing the problem using the same theme maybe? Sounds like a javascript issue.

I am having the same issue does any one have a solution?

Having the same problem too, no know recent changes. Currently investigating.

I’ve fixed it! It appears to be a cloudflare issue. I’ve not made any changes and it only appears to affect the S2member plugin. Rocket loader I think was the main culprit

By the way, I now believe I have got to the bottom of the issue. It is due to the fact that cookies are now blocked if they do not properly use the samesite attribute in chrome. It was picked up previously and yet to be dealt with.
s2Member and Chrome 80's new Same Site cookies.

1 Like

Hi all, back again, have the same problem but this time I have the Rocket-loader at Cloud Flare turned off completely. Can you guys check yours? Same problem on Safari, Chrome and Firefox, it does not allow CC info to be added again. See here.
Sarah :frowning:

https://incommunion.org/join-the-opf-get-involved/pdf-journal-quarterly-subscription/

1 Like

James, I have tried turning off cloudflare and turning off the rocketloader completely. Any tips for me?
Thanks in advance S xo
:pleading_face:

:slightly_frowning_face:

Hi Sarah, if you log in to cloudflare there is an option in the front page of your site in bottom right hand corner to pause cloudflare on site.

I can turn my issues on and off by enabling and disabling it.

Thanks for the quick reply! I tried that but it seems to stay… I emptied every cache I can think off… I will try again though! Let you know how it goes!
S

Argh problem still there… CloudFlare is paused. I dumped cookies, cache, and disabled the sites cache plugin… Can anyone load my page and enter data into the stripe field? :anguished:

https://incommunion.org/join-the-opf-get-involved/pdf-journal-quarterly-subscription/

It can sometimes take a while to update, best of disabling and checking back in an hour or so. Sometimes in different devices too as there won’t be any cache there

Ah, okay, thanks for that. :crossed_fingers:
I will wait…
S
xo

image

Cloudflare is not your issue now. Are you using any plugins that effect how js loads on your site?

Hmmm, uh oh, I think you might be right. That looks like the theme plugins!
I disabled the two I think they are… You are seeing that error in Chromes dev tools?
S

The gdlr… is the issue I think… but I removed them and the issue is still there.
But I dont have any javascript plugins on or anything.
The Cache plugin is deactivated…

Oh no, I think its the theme itself, this bad…
And I think it has something to do with cookies?

Reject insecure SameSite=None cookies

https://www.chromestatus.com/feature/5633521622188032

And it turns out it is a .js issue… in my case. The theme just issued an update. I will run update it and see if that helps.

Fingers crossed :crossed_fingers: