Stripe form suddenly broken - Urgent help needed :)


I was wondering of someone could help.

We use S2 Member Pro on a clients site and recently noticed that the form now has extra fields and users are unable to enter their card details. The form is loading perfectly fine on Chrome InPrivate browsing.

We’re tried clearing the server and website cache but still no luck.

Any help greatly appreciated.

Thank you

Hi Charlotte.

Can I have a link to the page with the problem?

That sounds like the the form’s JavaScript not working, probably not even being loaded.

If you didn’t change anything recently, then it’s not likely to be a plugin conflict. What I have seen reported recently a few times was s2’s JS file not being served by the server due to a strict configuration of their security settings. See: Failed to load resource: the server responded with a status of 403 ()

Let me know if that helps! :slight_smile:


Thanks for your reply.

This is the page which features the form at the bottom:

I shall contact my hosting provider today and mention your suggestion in the previous thread.


I’ve spoken to our hosting and they have confirmed that they’ve recently added a new feature which restricts the direct access to PHP files.

I’ve enabled the PHP direct access and it seems to have resolved the problem.

Thank for your help :slight_smile: