Mysterious New Registers issue

I seem to be having an issue where new paying members are having their accounts deleted somehow.

The transaction posts through stripe successfully, and they’re able to login initially…

…then the account seems to disappear in the wp backend.

I’ve been having to go in and create a new user account for them and then connect their customer ID from stipe into their profile to give them access.

Is there any way I can address this issue?

Everything is up to date.


For whatever reason, I’m still getting this issue and have been unable to find a solution.

It seems to be these two main issues.

  1. The user completes a transaction account and makes a username and password. The user tries to make a new password, but the “request password link” says it invalid.

  2. I get notifications that a particular user is requesting a new password in my email, but I don’t see any of their info in the database.

Also - I have done test payment with stripe on test mode, and the process works fine.

It just seems to be an issue with random customers that is happening in a way that I can’t seem to replicate.

Would love some assistance here.


Hi @markus.

This sounds like a variant on your previous problem related to customers “getting kicked out”. Your previous problem and now this problem are unusual and they both sound like a collision with another plug-in or a collision with the theme. Can you list theme and plug-ins so we can isolate a likely suspect.

Also…are these single WP sites or sites within a multi-site WP?
Are you running them in shared hosting, cloud-hosting (1 VM per site) or Managed hosting (typically containers)?


It could be but I don’t think this is a variant. Here’s why.

The previous issue was that users were logging in and then all of a sudden redirected back to the login/sales page when attempting to access a restricted page, as if they didnt have access. What’s weird is if they went from the login page and navigated to say the members page, occasionaly it would let them in.

The redirecting to login/sales page would be random and sporadic. Also if was for a completly different site.

With this issue here what the beats seem to be.

1.User fills out customer info and cc info on stripe form.
2. User then creates username and password
3. After username and password created, user tries to make a new password.
4. User receives email from wordpress with new password activation link.
5. User clicks the link, but then the page says the link is invalid.

I’ve asked them to clear cache, use link immediatly after requesting new password. Neither seem to be what was causing the issue.

Another weird thing is this.

When I try to look them up in the s2member database, there is no username or email data that exists.

I assume there would be because when a user requests a new password, I get an email about it, so I know on some level, the username exists.

This happened with 3 different customers yesterday.

I think somehow, the fact that their user info not being in the database is the reason why the link is invalid.

It’s very strange.

And to answer your questions.

List of plugins:

backup wp
carousel slider
chekc email
eform - wordpress form builder
gamipress login rewards
gamipress leader boards
gamipress leaderboard include/exclude
jwplayer plugin
limit login attempts
ninja popups
optimize builder
optimise press
optimize dashboard
s2member frameworkd
s2member pro
wordpress importer
wordpress user consecutive login counter
wp fastest cache
wp mail stmp
wp user avatar
yoast seo

They are single sites.

Managed hosting w/ godaddy.

Thanks Tim.

Ok. Quick win…drop the limit login attempts plugin…it is likely to thrash with the S2Member plug-in brute-force login protection. S2Member brute-force login protection is all you need. I only use limit login plugin on sites that I do not install s2member.

Okay - I’ve deactivated it. So you thnk this is what was causing the conflict? Hopfeully that worked.

Man it seems like one thing after another - I just received another email from someone who said when they’re trying to start a pro plan, they get this error.

"Invalid parameters to Stripe; please contact the site owner."

I just went through the process however, and it worked fine for me? Any thoughts?

Who manages your client’s stripe account…you or them? Someone needs to keep on top of the API version and API credentials to ensure there is a match between Stripe and the S2Member plug-in API version.

I do. Should I refresh the apis?

Is this setup causing conflict? The fact that there’s two s2member plugins. I only remember there being one when the pro version was activated.

There are two s2member plugins…the pro plugin extends the free plugin. You need both installed for a Pro installation.

Regarding APIs…I can’t really afford to take you through the whole Stripe API / S2Member process. Sorry. You’ll need to dig into the Stripe docs and the S2Meber docs and figure it out. Just make sure that their versions match.

Okay thank you.

Hi Marius.

Why are they setting a username in a step after the Stripe form? Are you using s2Member’s pro-form for Stripe, or some other form? Maybe using the eform builder I see in your plugins list?

s2Member’s Stripe pro-form would sign the user up, one of the fields is for the username. Can I see what you’re using?

You can also enable logging with s2Member, so we get more details to help troubleshoot. WP Admin > s2Member Pro > Log Files


My apologies. I misspoke.

You’re right. The username IS in step one.

So they submit payment after creating username…and then the process is complete.

The get the email with the link to create password.

Then they login.

Then after - it seems that their info (username, email, etc) in the wordpress database is gone. It disappears.

I think the real culprit is their info disappearing. It would explain why the new password link is invalid since it showing that they’re not a member.

Just to be clear: these are users who had previous access just minutes before as well as an active current paid subscription in stripe.

For example, I just had a user who was able to log in. Now they’re saying…

"I was able to make an account but I’m having trouble logging in, it only works on specific browsers "

I try to look them up by name or email, and there is no info.

Very strange.

Ah ok, got it. Yes, very, very strange.

If you could check your s2Member logs to see what they say about the account being created, that’d be good to confirm.

If they get an email about setting the password, that means the account got created…

I know it seems related to s2Member, but at the same time I’m not sure it is. The account creation, and password setting, use the WordPress routines.

I’m guessing there may be something else about your installation that could be introducing this behavior…

And is it happening for everyone, most, or only some few “random” ones? Could you reproduce it yourself?

Can you write a list of steps to reproduce it consistently? that would allow to inspect what’s happening.


Hi Cristian,

Should I send you me logs files? Would you be able to take a look?

Agreed - the account is getting created.

I would say it’s happening to 70% of new members, randomly.

I haven’t been able to reproduce it.

Here’s one thing that mya be helpful, when I recreate the logins for them manually to give them access, it works comepltly fine.

I can’t think of actual steps to reporuce it other then the steps that new customers take before experiencing this issue, which I stated above.

Hope that helps.


While rummagin around, I did find this…

In this “stripe webhook/ipn integration” i did notice that their is a different website placed in my “webhooks endpoint” in my stripe account.

It seems like the site “” is placed as an endpoint, but not which is the site having issues.

Could this be causing conflicts?

Or could it be a cache plugin?

I’m currently using " WP Fastest Cache

Lastly - I changed the s2member email config to a domain domain. Not sure if that would fix it.

This one seems like a tough nut to crack.

I’m still getting users who:

make a purchase and create logins
login and access the training

…then after a few hours, their profile info is gone.

Just to add - I’ve enabled logging and have uploaded a WP MAIL log plugin if this could help…