I'm seeing Checkout Options on a page where I shouldn't see them

I have checkout page where I generate the checkout form using this shortcode:

[s2Member-Pro-Stripe-Form ccaps=“course_1046” desc=“Open Rose - $45” ra=“45” level=“1” cc=“USD” custom=“louisejacksonpaintingclasses.com"ta=“0” tp=“0” tt=“D” rp=“1” rt=“L” rr=“BN” coupon=”" accept_coupons=“1” default_country_code=“US” captcha=“0” /]

This seems to have been broken in the last couple of months as it was working fine until sometime in February. I’m not sure of the exact date it stopped working. I have a test page you can reach below:

https://wordpress-193604-1859935.cloudwaysapps.com/index.php/membership-options/

I am also getting an error on the page loading a resource, the following is repeated four times on the Javascript console four times:

s2member-o.php:1 Failed to load resource: the server responded with a status of 403 ()

https://wordpress-193604-1859935.cloudwaysapps.com/wp-content/plugins/s2member/s2member-o.php?ws_plugin__s2member_css=1&qcABC=1&ver=210208-210208-526143882

I’m getting the issue with a fresh install of s2Member and I downloaded a fresh copy of s2Member-Pro on a new Wordpress installation. Can someone help?

Just to be clear on the seeing the checkout options… I’m only using the one shortcode, I’m not using nested shortcodes that I believe ought to result in the checkout options dropdown. Also, there are no options populated in the checkout options dropdown.

Hi James.

That seems related to this: https://s2member.com/kb-article/mod-security-odd-403-503-500-errors/

I already had two other users report this problem with Cloudways recently. One of them got it sorted out and is now working for him. See: Failed to load resource: the server responded with a status of 403 ()

I hope they sort it out for you quick too. :slight_smile:

Thanks Cristián!

I’ll work with Cloudways on this.

Issue is solved. Cloudways has a new setting to turn on direct PHP access for each applications. For sites that do not require this access it ought to be safer to turn it off but for s2Member (possibly only s2Member Pro?) you need it on (at least in the current versions).

1 Like

Nice job!

Thanks for the update and the details! I’m very glad you were able to sort it out.

:slight_smile: