Wrapping multiple shortcode options at payment and some options not showing

Hey

s2member newbie (and website builder newbie tbh) and I’m having an issue with wrapping the shortcodes on my payment gateway.

There are 4 options - 2 different time scales for membership with an option for each whether you buy outright, or pay monthly

I can quite happily get all four options to display HOWEVER, when I add a custom success page to all four shortcodes only 2 options display in drop down on purchase page. Deleting the custom success page from all but one shortcode option means they all display…

The code below is what I’d like to run - with the success= highlighted in bold on first option causing the issue. Deleting this and all options then display. Having it in and only top 2 options display.

(I’ve had to delete the link out of the rest of the shortcodes and replace with ****** as I’m new and can only add a couple of links per post!!!)

[s2Member-Pro-Stripe-Form]

[s2Member-Pro-Stripe-Form level=“1” **success=“https://aeonhaf.co.uk/vipaccsuccess/”** ccaps=“fast” desc=“£179 GBP / One Time FAST TRACK TO FAT LOSS (for 2 month access, non-recurring)” cc=“GBP” custom="" ta=“0” tp=“0” tt=“D” ra=“179” rp=“2” rt=“M” rr=“BN” coupon="" accept_coupons=“1” default_country_code=“GBP” captcha=“0” /]

[s2Member-Pro-Stripe-Form level=“1” success="******" ccaps=“fast” desc=“£119 GBP / Monthly FAST TRACK TO FAT LOSS (recurring charge, for 2 months)” cc=“GBP” custom="" ta=“0” tp=“0” tt=“D” ra=“119” rp=“1” rt=“M” rr=“1” rrt= “2” coupon="" accept_coupons=“1” default_country_code=“GBP” captcha=“0” /]

[s2Member-Pro-Stripe-Form level=“1” success="*******" ccaps=“tg” desc=“£499 GBP / One Time TRANSFORMATION GUARANTEE (for 6 month access, non-recurring)” cc=“GBP” custom="" ta=“0” tp=“0” tt=“D” ra=“499” rp=“6” rt=“M” rr=“BN” coupon="" accept_coupons=“1” default_country_code=“GBP” captcha=“0” /]

[s2Member-Pro-Stripe-Form level=“1” success="********" ccaps=“tg” desc=“£99 GBP / Monthly TRANSFORMATION GUARANTEE (recurring charge, for 6 months)” cc=“GBP” custom="" ta=“0” tp=“0” tt=“D” ra=“99” rp=“1” rt=“M” rr=“1” rrt= “6” coupon="" accept_coupons=“1” default_country_code=“GBP” captcha=“0” /]
[/s2Member-Pro-Stripe-Form]

Thanks for any advice!

Hi Ben.

It’s odd that the success attributes in several options would be a problem…

First I’d suggest simplifying the shortcodes. You can move to the parent one all the attributes that are common to every option. If the success redirection is the same for all options, then you can stick it there as well, side-stepping the issue you mention. Also, the success address doesn’t need to be a full URL.

Also, the country code would be GB, not GBP, that’s the currency. And the custom attribute has to have your domain name, so I included it. See: WP Admin > s2Member Pro > Stripe Pro-Forms > Shortcode Attributes

So you get something like this:

[s2Member-Pro-Stripe-Form level="1" custom="aeonhaf.co.uk" cc="GBP" ta="0" tp="0" tt="D" coupon="" accept_coupons="1" default_country_code="GB" captcha="0" success="/vipaccsuccess"]
  [s2Member-Pro-Stripe-Form ccaps="fast" desc="£179 GBP / One Time FAST TRACK TO FAT LOSS (for 2 month access, non-recurring)" ra="179" rp="2" rt="M" rr="BN" /]
  [s2Member-Pro-Stripe-Form ccaps="fast" desc="£119 GBP / Monthly FAST TRACK TO FAT LOSS (recurring charge, for 2 months)" ra="119" rp="1" rt="M" rr="1" rrt= "2" /]
  [s2Member-Pro-Stripe-Form ccaps="tg" desc="£499 GBP / One Time TRANSFORMATION GUARANTEE (for 6 month access, non-recurring)" ra="499" rp="6" rt="M" rr="BN" /]
  [s2Member-Pro-Stripe-Form ccaps="tg" desc="£99 GBP / Monthly TRANSFORMATION GUARANTEE (recurring charge, for 6 months)" ra="99" rp="1" rt="M" rr="1" rrt= "6" /]
[/s2Member-Pro-Stripe-Form]

Could you give it a try?

I hope that helps. :slight_smile: