User Lists - Not working by role

None of these are working

[s2Member-List roles=“subscriber” /]
[s2Member-List levels=“0” /]
[s2Member-List levels=“1” /]
[s2Member-List levels=“2” /]
[s2Member-List levels=“3” /]

Comes back “sorry there are no users to list”

Only this works: ```
[s2Member-List /]

I have users in each role. It DID work before  A little concerned.

Hi Vincent.

I just tried your examples, and also had trouble with it. The level parameter was being ignored and returned all users, while the ccap one wasn’t finding any user with it.

I noticed that the quotes around the attribute’s value in your example, are curly double-quotes, which break shortcodes. When I changed them for the straight double-quotes, then the results were correct and the proper users lists were displayed.

It’s possible that your WP editor changed them on your page for some reason…

Could you try these?

[s2Member-List roles="subscriber" /]
[s2Member-List levels="0" /]
[s2Member-List levels="1" /]
[s2Member-List levels="2" /]
[s2Member-List levels="3" /]

Let me know how it goes. :slight_smile:

Same problem. I deactivated plugins to check for conflicts, but no help.

I see… I can’t reproduce it on my site, it’s working well for me.

Can I take a look at your site and look at the editor for the page with it? Maybe you could give me access to an account with Editor role? I think that should be enough. You can message me privately with that if you want me to take a closer look.

In your conflict tests, did you deactivate every other plugin or only some? If you create a testing installation of wordpress, can you reproduce the behavior there?

Send pm

I got it working. I really can’t figure out what it is. Maybe my theme DIVI is corrupting the quotes. I kept typing these : " - and then only level 2 worked. I copied and pasted the level 2 to the others and changed the level and they all worked. Visually they all looked correct the first time.

1 Like

Nice job! I’m glad you sorted it out. Thanks for the update.