Stripe subscription charge issue


I’m hoping someone can help…I raised a request for help 3 weeks ago but haven’t heard anything other than the automated reply email.

Stripe is charging us a subscription fee for our membership charge from S2Member.

Even though we have created the charge as “1 year access, non recurring”, it is also priced at “NZ$40.00 every 365 days”. This is what Stripe is recognising as a subscription. For the life of me, I can’t find anywhere to change this setting (I assume it can be changed). Any thoughts?


Hi Antonia.

That sounds like a recurring charge, which would be a subscription. Is your intention that it gets charged automatically at the end of the year, or that the person manually renews it?

Could you show me the shortcode you’re using? If it’s a subscription, I can show you how to change it so it’s a non-subscription single payment.

If the user already subscribed with what you had, and you don’t want a subscription in PayPal, you can look for it and end the subscription. I believe it’d be from here:


Hi Clavaque. Thanks for your reply!

I would like it to be a one-off charge, that people manually renew after receiving an EOT email (these are not working for us at the moment - not sure why).

Here is the “subscription” shortcode:

[s2Member-Pro-Stripe-Form level=“1” ccaps="" desc=“Current Members (L1) / Description and pricing details here.” cc=“USD” custom=“” ta=“0” tp=“0” tt=“D” ra=“0.50” rp=“1” rt=“M” rr=“1” coupon="" accept_coupons=“0” default_country_code=“US” captcha=“0” /]


Apologies, this is the correct shortcode:

[s2Member-Pro-Stripe-Form level=“1” ccaps="" desc="$40 NZD / One Time (for 1 year access, non-recurring)" cc=“NZD” custom=“” ta=“0” tp=“0” tt=“D” ra=“40” rp=“1” rt=“Y” rr=“0” coupon="" default_country_code=“US” captcha=“0” accept_coupons=“1” /]

Please try changing that to BN: buy now. “0” makes it a non-recurring subscription, but still a subscription (useful to have a trial period, which buy-nows don’t have). WP Admin > s2Member Pro > Stripe Pro-Forms > Shortcode Attributes > rr

rr="1" Recurring directive. Only valid w/ Membership Level Access and/or Independent Custom Capabilities. Possible values: 0 = non-recurring “Subscription” with possible Trial Period for free, or at a different Trial Amount; 1 = recurring “Subscription” with possible Trial Period for free, or at a different Trial Amount; BN = non-recurring “Buy Now” functionality, no Trial Period possible.

Thank you! I will do that and run it for a while to see if that sorts it.

Are you also able to help with our EOT emails not sending? They don’t send to be triggering. I am testing by manually setting the EOT date in a membership profile. I am running an email log and there are no failed emails being returned, but there are no successful ones being sent either.

Is wordpress sending other emails correctly?

You could install a couple of plugins for wp-cron (the system that automates things like checking/sending emails): Cron Logger and WP Crontrol (or similar ones). Look for entries that mention s2Member’s EOT.

And if you haven’t yet, please enable logging, and after some reproducing the problem, look for logs that mention EOT in the name. WP Admin > s2Member > Log Files


Yes, WP Mail Logging says all other emails are sending ok.

I’ll try those suggestions and come back to you…


1 Like