Stripe form won't work

Hi
My stripe forms will not work… there is a dropdown for “options” which shows nothing to select, and the credit card # field is inaccessible…

How do I fix that?!
Don’t know what to look for.
Using shortcode in elementor - have tried both with the shortcode block and putting the shortcode in a text block…
of course it’s membership renewal time… so this is really lousy timing!

Hi Kera.

Could you show me your shortcode here?

Also, did you troubleshoot to see if there’s a plugin/theme conflict causing the problem? See also: https://s2member.com/kb-article/common-troubleshooting-tips/

Did you update something before the problem started?

Hi
Thanks for the quick reply.

shortcode is:
[s2Member-Pro-Stripe-Form level=“4” ccaps="" desc="$40 CAD / One Time (for 1 year access, non-recurring)" cc=“CAD” custom=“www.comoxvalleyarts.com” ta=“0” tp=“0” tt=“D” ra=“40” rp=“1” rt=“Y” rr=“0” coupon="" accept_coupons=“0” default_country_code=“US” captcha=“0” /]

I did not yet go through the troubleshooting because I’d just sent out a renewal email to a large portion of our membership, so didn’t want the site inaccessible or looking broken.

I have since replaced the stripe code with a link to pay via our square account - which means i’m manually updating, but at least people can pay without any roadblock, and it’s faster for me than having to respond to multiple emails about why they can’t pay online!

I’m unsure when the problem started… however, I had not HAD a stripe form available for a while because there were issues with it before. So, it’s possible it’s been a long time, and this renewal period I was hoping to automate more, but alas, manual updating continues.

Fortunately, it only takes seconds to update expiry dates, and we don’t have 1000s of members, only a few 100…

I will find some time to do the trouble shooting after this current marketing push has subsided, and report back.

1 Like

I have exactly the same problem on a new site built using Elementor, where I’m trying to add a membership function using s2Member and Stripe to the site.
s2Member and Stripe Pro-Form are working fine for me on another site I manage that doesn’t use Elementor, but which does use the same theme (GeneratePress).
I’ve tried putting the shortcode into a page that isn’t created with Elementor, just the classic WP editor, and I’ve tried it in Elementor, both in the special shortcode block and as embedded in a text block. Same result every time, as described by keramch above.
I’ve tried deactivating Elementor and a couple of other plugins that are not on the site where it’s all working, but nothing changes.

I found and fixed the problem on my site. There was a plugin conflict with a plugin called SG Security, a plugin that SiteGround automatically installs on a new WordPress site. Deactivated it and the problem went away.

I also had issues with SG security plugin. I made some tests and it it seems to work if you just turn off the first two features of SG security plugin : block and protect system folders / hide wp folder.

I have everything else turned on and sti stripe pro form is working. SG security plugin is especially nice for the log section and for 2fa.

Cheers
Leo