Shipping Address Needed - Stripe

Hey Guys,

I have a purchase option that requires me to ship product to the customer. I guess I have two issues but they may be related.

  1. I need to collect a shipping address
  2. I need that shipping address linked or passed to Stripe

I don’t need the billing address but even tried to get that (I know there are issues with that too.)

I know that I could add ‘custom’ fields to the registration but that introduces tons of wasted time looking up users and trying to correlate them and stripe. Not an option for me.

This seems like pretty basic functionality and there is a “collect_shipping_address” directive. It just does not seem to work. I am never seeing input fields and I am not being prompted anywhere.

Short code below: (Live in Stripe Test Mode: https://www.positiveparenting.com/purchase-options/purchase-class/)

[s2Member-Pro-Stripe-Form level="2" ccaps="" desc="$200.00 USD / One Time (for lifetime access, non-recurring)" cc="USD" custom="www.positiveparenting.com" ta="0" tp="0" tt="D" ra="200.00" rp="1" rt="L" rr="BN" collect_billing_address="1" collect_shipping_address="1" coupon="" accept_coupons="1" default_country_code="US" captcha="0" /]

Thanks in advance for any insight or help with this!

Hi Debbie.

I see… Those directives are actually a remnant of the older integration with Stripe. Jason added it because they were part of what Stripe asked for the modal that popped up for the customer to enter his card info.

s2Member is for digital products, access to WordPress content, and it was never part of the implementation to deal with shipping addresses. The new Stripe integration uses a newer Stripe API, where the payment field is in the same form instead of another window, and is just that: payment details. I had missed that attribute in the documentation, that’s why it remains, but I’ll remove it in the next release. Thank you for bringing my attention to it.

Having said that, some site owners in the past have needed to ship things to customers, and what they used were custom profile fields. See here: WP Admin > s2Member > General Options > Registration / Profile Fields & Options

Does that help? :slight_smile: