Setting Unrestricted content is just 'no restriction level', right?

This should be obvious, but I can’t seem to see what I am missing. I have a site that requires everyone to login to see various levels of content. I want to create a public page with no restriction, so left the Page Level Restriction? empty. Trying to navigate to that page still redirected me to a login form instead. I also tried setting it to “level 0” which is the public/all user level and had the same issue.

Is there a global “require any/all people to login all the time” setting someplace I am forgetting we set?


Setting it to level 0 will require everyone to be at least a subscriber, so that’s definitely not what you want. Leaving the box blank is the correct thing to do, but you seem to have a setting somewhere else that is restricting access to that page. I’d re-check your settings.