Setting new password / reset password after activation email - Stripe registration

I have encoutered strange behaviors in reset password form after activation email after Stripe free member registration.
I set “send each user a password-setup link after registration” in s2member settings.

After clicking the activation link:

I get form with 2 fields. When I fill first field called “New pasword” and try to fill “Confirm new password” field - the first filed is cleared and I can’t write in the secound field.
It looks really strange.

Please help.

That’s very odd…

wp-login.php is a WordPress file, that form is not controlled by s2Member.

I suspect that some other plugin may be introducing that problem… I suggest that you try reproducing it in a test installation with just s2Member to see if you can still get that behavior. Could you do that?

I look forward to your update. :slight_smile:

Yes, I can try. I already have turned off the s2Member to see how this will work. The form is looking good and all is working perfect. I will let you know what are the results with new installation.

1 Like

The same problem with new installation. Please check my test web at I have set open registration. After registration, following activation link from mail I have encountered the same strange form behavior.

Hi, can anyone help with this problem. I cant get new password set for new users, or reset password I have send this topic to support - but there is no reply. I guess the support didn’t answer me not even once to previous questions that I’ve sent. How can I get this module working?

Hi Maja.

Thanks for the tests installation. Sorry for taking long to get back to you.

I did a test registration and tried setting the password. There is some weird behavior in that form, it won’t let me confirm the password. The registration form also looked weird, though, although it worked.

Can I have admin access to that tests installation to inspect it? I’ll send you a private message you can reply with the login details.

I look forward to your update. :slight_smile:

Problem is solved, the strange behavior when adding styles to registration page. No styles = no problem.