S2member with Learnpress

I know you cant offer support on other plugins, but I have an LMS plugin called Learnpress. I created a course with lessons and was hoping to protect advanced lessons with s2member so they would have to upgrade to access.

but the LESSON pages are not recognizing s2member restrictions (levels or ccaps)

I setup a test level 1 member attempting to access a lesson that supposedly only level 3 can access. But it can be accesssed with no problem.

The particular lesson is picking up s2member shortcodes such as name, etc, but doesn’t restrict the page. And the page id numbers don’t appear in " Page Level Access Restrictions (optional)" for level 3.

Any ideas?


Hi Vincent.

I don’t know if it’s related to LearnPress. If you deactivate it, does the restriction work?

How did you apply the restrictions?

In the pages list, on thage page’s row, at the right, does it have an icon indicating s2Member protection?

When you edit the page, in the s2Member metabox, does it mention the restriction there?

Did you verify that you entered the correct page ID in the restriction box? WP Admin > s2Member > Restriction Options > Page > Level 3

s2member restrictions normally work fine.
I applied in the edit lesson (it’s a post type, and it has the s2member box to the right)
Yes, it has s2member protection icon
Yes, the correct IDs are there.

That said, when the 22 pages are set, they don’t show in the
restrictions options page level 3. And if I add them there, they dont’ show as icons.

I did however find an alternate protection: URI restrictions work. I guess I’ll have to go that route. I will have to rewrite my membership options page.


Glad you sorted that out. Yeah, URI restriction is very useful. :slight_smile:

It’s very strange that setting the restriction up on one place would not show up in the other…

If they are a custom post type, then you’d use the Post restriction, not the Page one. Just a comment in case you didn’t look there.

Oops ,you’re right, they were in the Post restrictions.

either way, don’t work but works with URIs.

I don’t know if that’s a concern. If not, I’m good with it that way.


1 Like