Prevent WP menus from catching

Hi, we are facing a lot of problems with wordpress menus and comet cache, they all mix together (top, mobile and footer, all mixed, after claring cache manually they all come back to it´s possition.

Could someone share some URI Exclusion Patterns, so menus are not cached?

We are really on a hurry, we have plenty of sites and all them are facing same problem.

Thanks in advance for any help :wink:

There is no support at all from Comet Cache? 25 days waiting some help and none support at all?

We have went too, to developers Wordpress Forum and 25 days too waiting for some help.

You can check here:

Seeing this we will probably install another catching pugin with better support, as there are tons of plugins and lots of competence.

We have being using Comet Cache plugin for years in all our sites, more than 10 job offers and seekers websites and recommending it to friends, with no need of support, BUT now that we need some support because our website menus (principal top, mobile and footer) are getting mixed all together in the top website menu (principal), breaking all site appearance, until we clean the caches manually so they return back to normal possitions, we don´t have any help…

We shall wait a week more, but if this keeps like this without support, we will have to say bye to Comet Cache :frowning:

Hi Trabajo,

Really sorry I missed this one the first time you posted!

Excluding only a part of the page from the cache, is not something supported, only if you then include it with JavaScript, for example.

But it’s strange that you’d get mixed up menus. Are they dynamic? or is one user seeing the menu of another?

Tell me, is this menu caching problem for guests or logged in users? Have you tested disabling logged in user caching?

I don’t think this may be related, but just in case, are you using HTML Compression? Have you tested disabling it?

Does it also happen with the default theme? What troubleshooting have you tried so far?

Can you reproduce this issue consistently? What would be the steps to reproduce it?

I look forward to your update. :slight_smile:

Hi Cristián and really thanks for answering!

I will go direcly to answer your questions:

  1. We have URI exclusion only for home page and for login page. We have the home page because menus got corrupted in fronpage, after doing this, only menus in single job offer pages got corrupted and in frontpage where all listings showed up, web menus showed well.

  2. We don´t have dinamic menus, we use flexsqueeze 2.0 premium wordpress theme, since a lot of years ago, since verion 1.0.

  3. This happens to all users, logged admins and users navigating in the site.

  4. There isn´t one user seeing a menu from another, they all get mixed in top of the site, For example if in footer there is the cookies page, privacy page, blog page and all others, and in mobile there is home, jobs, seekers registration, companies registration, etc… and in top menu (principal), there a few too, they all get mixed into one HUGE menu, with tons of links to pages, so gets really weird.

  5. We have disabled the HTML compression too, but everything looks the same.

  6. We disabled Comet Cache and stopped doing this.

  7. After turning on Comet Cache, things came back againg with menu problems.

  8. Yesterday we configured Comet Cache to autoclean caches every 2 minutes and stopped breaking menus, as cleans every 2 minutes, but for this we don´t really take advantage of Comet Cache, as we used to have it to autoclean every 7 days.

  9. And about logged in users, doesn´t mind, as we tested logged in and logged out and things are just the same.

My question would be, If I don´t catch some part of Flexsqueeze theme, maybe would stop doing this? But I´ve tryed to not cache:

wp-content/themes/flexsqueeze2/header.php (didn´t solved it)
wp-content/themes/flexsqueeze2/admin (didn´t solved it)
wp-content/themes/flexsqueeze2/index.php (didn´t solved it)

and so lot of others, with no luck.

Maybe there is someplace for not catching menus?

There is something we can´t find that makes this menus to be mixed, so when we disable the Comet Cache works fine, when we enable Comet Cache and clean cache works fine, but when the page starts getting cache after a few minutes/hour all menus get mixed untill we clean cache again.

Hopefully you can help us, as you probably know a lot more than us.

Thanks Cristián!

Thank you for giving more details about how it’s behaving.

Hmm… Interesting behavior. So Comet Cache builds the cache, and then the problem is not inmediate, it builds up over time.

That’s strange. I wonder where that theme is populating the menus from, and if they’re cached, why are they changing?

Can I have a look at the site? You can message me privately.

Thanks. :slight_smile:

Hi Cristián, I can´t find how to send you a private message, I´ve looked all over and finded messages, but there is no option to send PM. Thanks!!

Click on my name, and in the popup there should be a message button.


Hi Cristián, I did all that yesterday, there is no message button clicking on your name, either clicking in your profile, that blue button doesn´t appear anywhere, this is why I wrote back. Any other way for communicating? Thank you!

Weird that you don’t get it. I need to search the forum configuration to find why that would be the case…

You can email me to too. Include a link to this thread as reference, please. :slight_smile:

Hi again, I just wrote you thru email :wink:

And, if you need my credentials to see here at forum how I see my backoffice, so you can check the missing PM button, please don´t hesitate to ask, will be a pleasure :wink:

Thanks a lot for your help!

1 Like

Got it. Replied by email. :slight_smile: