Multiple PayPal payments charged but no membership created

In the last 12 hours I’ve had multiple sign-ups fail on two of my sites. The payment is processed through PayPal, but no membership is created. The customer sees and error and tries again. They are charged again on PayPal, but again no membership is created. Once customer tried 4 times. They are then contacting me but the only error they are reporting is “Error. Please contact Support for assistance.” I am seeing the same error in the paypal-api.log:

-------- Output string/vars: ( Sat Apr 18, 2020 1:22:01 pm UTC ) --------

array (
‘__error’ => ‘Error. Please contact Support for assistance.’,

I can’t tell if this is a PayPal issue or an S2Member issue. Everything was working fine until last night. The first failed registration was at 6:01 PM EDT on April 17, 2020. There were some successful registrations after that, but as of today it looks like everything is failing.

Anyone have any ideas on how to resolve this? Where should I be looking to find the source of the error?

I use PayPal with s2Member (Pro) and I’m not seeing the issue. I tested it just now by signing up as a new member and everything worked fine. Payment was accepted and membership was created.

I think there are a lot of variables here, and I need to narrow down the potential issues. Here are some more details:

  1. I’m in Canada, and have a Canadian PayPal account
  2. Payments with errors are coming from all over the world, including Canada
  3. Payments with errors are in US and CAD dollars
  4. Last night, the problem appeared intermittent, but now appears to be continuous. This leads me to believe that it is a PayPal issue. They may have pushed an update that broke my particular way of receiving payments, which is “Website Payments Pro”. The intermittent aspect would be because they update their servers individually, so someone hitting a non-updated server would still work. This is speculation.

I expect I’m going to spend the next few hours on the phone with PayPal. Not exactly what I was planning to do today :frowning:

I’m also in Canada, using Website Payments Pro, and I am not experiencing the issue. I’ve had several membership signups today and no reports of problems.

Curious to know what you find out.

Did you ever figure out what was causing the issue? I had a similar issue today. Received a payment via PayPal for a one year membership but no membership was created in s2Member. I had to add the user manually. Never had that happen before.

A number of people have been reporting issues with inbound IPN messages that are not being received. In some cases it was caused by a WordPress security plugin, other cases it was a CURL update by their host, and in other cases the message is not getting through based on what looks like intermittent network congestion. Have a look in your PayPal developer logs and look for an error from PayPal attempting to send an IPN to s2member. See

Thanks Tim. Is it Live API Call History that I should be checking? Mine shows no history at all. I must be looking in the wrong place.


No luck with that either, but thanks for trying. I’m just going to chalk it up as network congestion unless it happens again.


Also…contact PayPal support if you can’t find message logs. They should be there.

Found it. And it says the IPN was sent. No error messages. So, I don’t know why the account was not set up.