Mailchimp not adding S2 members

Hi Cristián,

I’m getting this error on the log file for Mailchimp integration that I just setup. Any ideas how I can solve it:

[line] => 227
[function] => castError
[class] => Mailchimp
[type] => ->


Hi Norm,

Where are you getting that? An s2Member log? What do the s2 logs say about it? Can I see the full entry? Wp Admin > s2Member > Log Files

Did you check that the integration is configured (API Key, List IDs) correctly? WP Admin > s2Member > API / List Servers > MailChimp


Hi Cristiàn,

Thanks for getting back.

The error was from the S2Member log. How do I get the log to you? Did the API and IDs which all look OK.

Hi Norm,

You can zip it and try sending it in a private message, or upload it to your site and message me the link privately. Click on my name, and then the “message” button.


Hi Norm,

Thanks, I got the message and could see the page you sent me.

It still doesn’t help me fully, though. Do you think you could reply to your first message, to show me screenshots of your configuration?

Also, are you using the custom code to add merge fields to the MailChimp subscription, and can I see it? E.g.


We’re not that technically minded here Cristiàn so not sure about the custom code and merge fields.

I’ll put the screenshot on the first message.

Hi Norm,

Thanks for the additional details you sent privately.

I studied the log you showed me, and see that the error is basically that there’s an MMERGE2 field missing for the user.

[message:protected] => MMERGE2 must be provided - Value must be one of: Yes I'll accept your emails with special GIFTS for me, offers and important news. And I can unsubscribe anytime. (not Test)

It looks like you may have created this merge field for that audience in MailChimp, and made it required. Because s2Member is not sending that field, then you’re getting the error…

If I understood correctly, then you’d either have to uncheck the “required” box for that field in your MailChimp configuration, or you’ll need to customize s2Member to send MailChimp that field for the subscriber.

One way to get to the merge fields settings page would be: MailChimp Dashboard > [select the audience] > Audience > Tags > Settings > Audience Fields and Merge Tags


You’re a star Cristiàn that worked perfectly. Thanks for your time and all your help.

1 Like

Great! Thanks for the update :smiley: