Login user gets 503 error

I have three members who are experiencing issues with this error:
Login user gets 503 error and too many IP addresses statement

Two are in Europe, and one is in North America.
One is trying to log in with two devices, one is not (the other, I don’t know).

I tried following the instructions on this page: https://s2member.com/kb-article/why-are-my-users-seeing-too-many-ip-addresses-accessing-one-secure-area/

I changed the number from 0 (disabled) to 50. Still no change.
I thought of clearing the cache of the site. Still no change.

Where else can I look for a solution?

Could it be because they are using IPv6 IP addresses? Someone here mentioned that s2Member is not compatible with IPv6. I’ve been running into this issue regularly with one of my members. Oddly it seems to be just the one member. No one else reports it.

I would not know about IPv6, although I had issues with some emails not being delivered and I had that mentioned in the error, but it was for something else.

The puzzle is that the people had no issue before. One reported it last week, and the other two just these past few days.

@clavaque Is there anything that might have recently changed (Windows?) that could trigger this type of issue?