Htaccess help, mostly for Jason but will accept others help

Hi Everyone,

I asked this in the s2Member area and Tim had said to turn of the trailing slash option in CometCache. I would like to if possible just disable the trailing slash at the folder s2member-files. I am hoping someone knows how to do this in this side of the group.

Is this the correct info to do that?

RewriteCond %{REQUEST_URI} !(?:^|/)wp-content/plugins/s2member-files(?:/|$) 

I know how to do root level stuff but not sure about nested directories. Basically I just want to tell CometCache it can still allow the trailing slashes except for the wp-admin folder and the directory in s2members files.

The reason for this is I can’t get s2Member to use Amazon s3 with CometCache enabled and I am going on Tim’s suggestion on turning this function off.

For Jason if there is any input you could direct me to I would greatly appreciate it.

Thanks for any help,


Hi Ross :slight_smile: This line by itself looks fine, but can you paste the full context in which this condition is applied? I’m not sure exactly what you’re trying to accomplish with this yet, but maybe if I see the full context it will hit me.

Can you paste an example link that you’re using to reference a protected file; i.e., a link that is not working when Comet Cache is running. I’m not aware of a conflict between these two, but perhaps if I see the links you’re using that will shed light on a possible solution.

Hi Jason,

Jorry for the delay, this was an extremely busy month for me.

Basically the ending with a forward slash on all posts in Comet Cache broke the s2Member plugin when using it with Amazon’s s3 services. I was looking to remove the condition on just the s2members-files directory so I could leave that function on while still providing the files to be distributed by Amazon.

For the moment I have just removed the option altogether in Comet Cache. I will work on this at a later date on adding the htaccess line.

If this will work for Comet Cache then it is fine with me but it sounds like others have had the same issues on some servers. It was from another member that was able to shine light on the subject on why it only worked when Comet Cache plugin was disabled.


Sorry Jason,

It would be for the CORS policy area of my htaccess area. I have my server set to strictly allow only content that I I have granted from other servers that want to injected scripts and files into my site. For some reason adding adding the trailing slash in CC broke s2Members abilities to use Amazon for hosting the downloads.

I can get you a copy of the CORs policy if you need it.