Fatal error: Illegal length modifier

Yesterday, someone tried to join the membership and got an error when clicking on the Paypal button. I tested and whatever platform or browser is used, the error is the same. It does not happen with a Buy Now button, but for a membership only. I tried on a page using Elementor as page builder, and on a page using the classic wp editor, with the same result.

I tried reinstalling s2M and s2M pro. Same result.

Here is the error I am getting:
Fatal error: Illegal length modifier specified ‘f’ in s[np]printf call in /home/creat419/public_html/scrapbookcampus.com/wp-content/plugins/s2member/src/includes/classes/utils-cur.inc.php on line 18

The pages you can check are these:
https://scrapbookcampus.com/creative-scrap/diamond/ (this is using Elementor)
https://scrapbookcampus.com/creative-scrap/diamond-3/ (this is using WP editor)
https://scrapbookcampus.com/master-classes/further-vectors/ (this page has a Buy Now button, not for a membership)

I am not sure if it has anything to do with the pro-form vs button though.

Can you take a look in that file on your customers server. There is nothing on line 18 of that file that would give that error. This is the code at line 18 of that file:

if(!defined('WPINC')) // MUST have WordPress.
	exit('Do not access this file directly.');

Thanks. After reinstalling s2M, and reactivating it, the problem “magically” disappeared, and the customer in question was able to join the membership as if nothing was wrong. So I am not sure what was the issue, but for now, it is solved.
Thanks anyways.

Weird! Glad it’s working though.