Error: User registration is currently not allowed

Hi Forum

I have some Custom Registration Fields set up and when logged in as Admin the registration page at /wp-login.php?action=register looks fine with the custom fields.

But when I, and my new users, are not logged in then we see the default …com/wp-login.php?registration=disabled page.

I did see that Login/Registration Page Customization option appeared to have been unset.
So I reset. That didn’t help.

So I tried
1/ deactivating the s2 member framework and pro plugins
2/ ticking anyone can register in WP General Settings
3/ reactivating the s2 member framework and pro plugins
4/ resetting the Login/Registration Page Customization option

That didn’t help.

So I downloaded the previous version 230815 and activated and cleared my cache but that hasn’t helped.

FWIW I see that the actual registration URL sent to my user is …com/?s2member_register=ZGVmNT etc etc and that redirects to …com/wp-login.php?registration=disabled which I guess is standard behaviour.

Any insights or tips would be most appreciated guys.


I have the same issue. It started to appear after the latest update.

Hmm. Maybe - that would make sense.

But I have reinstalled version 230815 + s2Member Pro v220421

  • deactivated the plugin
  • reset anyone can register
  • cleared my cache
  • reactivated the plugin

and still get the same problem…

Yeah I keep on having this problem too from time to time with newest version. Also probs with password reset emails not sent randomly

Hey @clavaque - are you able to offer some feedback on this issue?

Hi guys.

I haven’t seen this myself yet and this is the first time I see it mentioned. That’s very odd behavior…

The latest release doesn’t touch that part… and you’re also having the problem with a previous release now, where you didn’t have it before… or you have it from time to time, not al the time…

From those details, it’d seem to not be related to the release other than a time coincidence…

If you have the means, can any you reproduce the behavior in a clone of your site, but then deactivating the other plugins? How about a clean wordpress installation with just s2Member? How about that in a different server?

Do you see any related errors in the php log?

FWIW I see that the actual registration URL sent to my user is …com/?s2member_register=ZGVmNT etc etc and that redirects to …com/wp-login.php?registration=disabled which I guess is standard behaviour.

I don’t know if it could be a problem with cookies, that the user didn’t get them set in his browser correcty after the payment and that’s why he’s not allowed to register if Open Registration is disabled…

But even in that case, the link sent in the confirmation email has an authentication that would allow the registration, and it sounds like that links is the one you try and still isn’t allowed.

That’s definitely not a normal s2Member behavior. Do you have anything else in your setup that could be interfering with the registration? The clean install or disabled plugins tests mentioned above would help see that.

I did see that Login/Registration Page Customization option appeared to have been unset. So I reset. That didn’t help.

Do you mean you make changes to s2’s options, save, and then when you check again they changes are lost? WP Admin > s2Member > General Options


Thanks for the suggestions @clavaque - I’ll work through them and get back.

1 Like

I don’t have that problem after downgrade but never had so many users complaining about password reset emails not sent, went back to old version and no complaints so far and also no complaints about registration currently not allowed while before twice in two days. Usually that’s once in a month. And yeah this randomly actually happens to users though I don’t know why. Always assumed problems communicating with PayPal

1 Like

Thanks for the additional details.

Would be good to have a mail logger, too, to see if those missing emails actually left the site and didn’t reach, or weren’t even sent in those cases. That in combination with the s2 logs and WP debug log, could give some insight into this apparently random behavior.

I’ll work through them and get back.

Thanks :slight_smile:

Yes the emails were sent but the link to reset the password didn’t work according to the users.
As for the registration link that one randomly doesn’t work but usually a couple of hours later it will work. I guess there must be some connection to PayPal. After updating this was happening twice. Felt just like too much coincidence that I get 5 emails from users about problems within 36 hours of updating. It’s usually one email per week

Thanks for the details. I see what you mean.

So I think its working for me now - with the latest version of the plugin.
The hosts disabled cookie stripping on the website and that may have been the solution - for me at least.
I’ll let you know if I have any more problems.

1 Like

That’s great! Thank you for the update.


I have also same issue. If you got the solution please tell me also.

Hi @lynettafloretta

I’m not an expert but one or more of the following may help and in no particular order.

  • under s2 member general settings turn on ‘allow open registrations’ (may be a short term fix)

  • check with your host if they are stripping cookies or anything else in place that may interfere

  • revert to previous version of the plug-in

  • clone the site and deactivate other plugins / theme

This tutorial is useful for generating access tokens to test with.

Good Luck

1 Like

I figured out that my registration page was (website URL)/register and somehow the last update defaulted that page to be the Wordpress registration page. Thus, I was getting the error. I just created another page with another URL and inserted the stripe forms. That fixed the issue for me. Hope this help.