I get this message at bottom of html

Comet Cache is NOT caching this page, because the PHP constant DONOTCACHEPAGE has been set at runtime. Perhaps by WordPress itself, or by one of your themes/plugins. This usually means that you have a theme/plugin intentionally disabling the cache on this page; and it’s usually for a very good reason.

Is there anything I can do, or should I give up on CC???

With thanks in anticipation


  1. I’ve just clicked the link, and you don’t have CC running. I’m not sure what the point of providing the link is then.

  2. If something has set the PHP constant DONOTCACHEPAGE, no other reputable caching plugin will cache that page either.

  3. You need to identify what has set that constant. My guess is that it’s your slider. It probably won’t work if you cache the page.

Hi Tim

Thanks for your reply

  1. I think Cloudflare was hiding the fact that I have it running CC; I had it on development mode and it reverted before you saw my question. I have now temporarily disabled Cloudflare
  2. I was not comparing CC with any other program
  3. This is actually helpful advice. I have two sliders and have set cacheing off, one explicitly, and one by setting caching value to 0 hours

Any other suggestions?


Stephen, (2) was a response to your thought about abandoning CC. I was pointing out that if CC won’t work here, there’s no need to look for an alternative.

As for other suggestions, after having tried your About page and seen that CC is being disable there too, it seems that your slider isn’t the only candidate for setting the constant.

You need to test on a staging or test site by disabling your plugins and seeing when CC starts to work. Then, if appropriate, see if you could use an alternative that does not set the constant.

Hi Tim

Many thanks for your reply!!

I got to the bottom of this. Another Plugin ( 404 Page Pro ) had caused the problem, and the developer changed his coding to sort the problem.

So MANY THANKS. Much appreciated


Well, I am having the same problem. My website is . Please let me know what can I do to enable caching through Comet Cache Pro. Thanks.

I have the same problem.

Other caching plug-ins will cache.

I’ve removed them all their htaccess additions but Comet Pro will not cached because of that same error.

Can’t figure it out. is the site.

@azimpact: It’s not an error. Comet Cache is simply doing what something has told it to do.

You need to investigate what precisely has set that constant. You will need to turn off your other plugins and switch to a default theme, and see if everything works then. If it does, that confirms that something now deactivated is the cause of your problem. Then reactivate each item one by one and re-test to find the culprit.

You might want to do this on a staging site first.

Got it!

Turns out it was the WPBackup plugin.

To find it downloaded all the plugins then, searched in the folder for DONOTCACHEPAGE. That was the only plug-in that had it. Removed it and all it’s files and the cache started working.

Didn’t need it anyway since I have UpdraftPlus on there.


Hello Azimpact, Thank you for letting us know about your issue. I would appreciate if you please elaborately let us know about how you searched out for DONOTCACHEPAGE constant among in your plugins. Thank you.