Comet Cache Not Deleting -tmp/ Directories


I have a strange issue with the wp-content/comet-cache/ directory not clearing properly.

I keep finding endless multiple /cache-5d09d92025058126785878-tmp/ folders that keep building up and have what seems an entire copy of the site within.

Our site has is large, 3000+ pages. I checked the other day and the wp-content/comet-cache/ directory was in excess of 100GB! I manually cleared it via SSH to get some space back for now.

If I click clear cache from the WP Admin tool bar the /wp-content/comet-cache/cache/ directory clears but these *-tmp/ directories just stay and seem to multiply over time.

I have auto cache engine off.

Comet Cache Pro v170220

Can anyone shed some light here?

Hi Alex.

That’s a large directory! Well done spotting that.

Normally Comet Cache would remove older versions of the cache. I’d suspect a permissions problem. Make sure that the permissions are set so that CC can remove the files and dirs.

If you have an error log in your server, do you see any entries that could be related to this behavior?

I look forward to your update. :slight_smile:

I did check folder permission and everything is correct at 755 including these *-tmp ones. Also checked mod_security logs and I can’t see anything obvious.

We are on a dedicated server running WHM/cpanel

Does comet cache have a log system we can turn on and monitor? I couldn’t see anything obvious.

I would love to get to the bottom of this error. Directory is already back to 7GB +

I am having this exact same problem. If I don’t manually delete these directories via Filezilla then I run out of room on my GoDaddy server.

Any help would be appreciated.