Can't Mass Import Existing Users to Update Information with Advanced Import/Export ON [Works Normally if OFF]

Advanced Import/Export Tools on

Trying to import existing users generates the error below (for each existing user):

Line #1. Conflicting; the email address (, already exists.

I was successful usint the non Advanced Import/Export. Of course, I exported the non advanced version, made the changes I needed, reimported the file :wink:



Hi Sim.

That’s because if the row has a user ID, then the importer will try to update that user, it won’t try to create a new one. If the user doesn’t exist, it’ll give that error in the screenshot.

If you want to create the user, then the email address should not be in use, has to be unique (same for username).

I hope that helps. :slight_smile:

1 Like

Oh no. The point wasn’t to create a new user, but to set EOT for a few existing ones (or update any other information if necessary).

The screenshot above shows the successful processing (non advanced). The problem is with the advanced import, which is not working to update existing users.

I left the comparison to help people who might face the issue and, also, to let you know the advanced import isn’t updating existing users and giving that error message instead.

I see.

When you exported it, did you use the format for re-importation?

Could you show me here what your first line of the CSV file is? (redacting any private info) The line that you get the error/warning for.

Thanks :slight_smile:

1 Like

Thanks for your message!

I regenerated the file, since I overwrote it with the old format when I did the entire thing again, keeping only one line for your reference.

This was my procedure (the one that caused the error):

  1. Advanced Export/Import On (from start until the end);

  2. Exported all users with UTF-8 Flag ON (format ready for reimport);

  3. On Microsoft Excel, filtered and removed all lines for users I did NOT want to change (kept the top line which has the headers, of course, unchanged);

  4. Added EOT using UNIX format (like I saw you used for this file format) at the assigned EOT column;

  5. Saved the File (I redacted the attachment): (1.7 KB)

  6. Tried to Import the file and got the error.

I wish it’s helpful :innocent:

Meanwhile I am perfectly OK using the non advanced export/import :wink:

1 Like

The problem persists. I tried to use the advanced importation to import users I edited after exporting using your advanced option and I still get the same error. Instead of updating the information it refuses to do anything.

Could I take a look at your CSV?

And if you want, I can try updating a user on your site with the importer, to see if I can do it, or see what the problem behind it may be.

You can send me the details privately as before, of course.


1 Like

Yes! I sent to you via Private Message.

And the same as before, I was able to use the old format but the new one is more accurate and easier to work with if we can make it work.

Also, Excel is removing the quotes (with or without UTF BOM) but that’s not the cause for the problem because I ran a command to re-add the quotes and the conflict still persists (I added the command below in case anybody ever needs it).

import-csv "NameWithoutQuotes.csv" | export-csv "NameAfterReaddingQuotes.csv"  -NoTypeInformation -Encoding UTF8

This time I used the old format, since I had to process those users, but with yesterday’s date to force the EOT to run right away. Hopefully you’ll figure out what’s wrong and next month I’ll be able to use this tool to re-import users. I also want to use it to fix that other issue with stripe users not being updated in S2Member’s database by trying to add enough information on a batch (unless you have a fix for the plugin on the way?)

Thanks for the additional details and the CSV file.

Did you try just having the ID and EOT time columns in the CSV, as shown here?


I did a test to update the EOT time of some users in my own tests installation, and it worked fine.


1 Like

That is AWESOME! I will surely try it out, I didn’t know I could do that!! I thought I had to fill up all the fields.

So… Does it mean I can also do it for that problematic field that is supposed to have the meta tags that are missing when I reupgrade users manually?

That’s surely neat!

And… Does it have to be by ID or can I use other field like the PayPal Payment ID instead? It would be handy when I receive messages saying a payment failed, I could just set the EOT in one column and the PayPal Payment ID on the other. Same with sub and cus ids from Stripe and so on. :thinking:


1 Like

yep :slight_smile:

1 Like

Sorry I edited my comment while you were answering LOL.


Has to be the user ID. When it’s an update, you use the ID. When the importer gets a user ID, it does an update.


1 Like

Perfect! I will test it later.