Can't Mass Import Existing Users to Update Information with Advanced Import/Export ON [Works Normally if OFF]

Advanced Import/Export Tools on

Trying to import existing users generates the error below (for each existing user):

Line #1. Conflicting; the email address (redacted@redacted.com), already exists.

I was successful usint the non Advanced Import/Export. Of course, I exported the non advanced version, made the changes I needed, reimported the file :wink:

image

:slight_smile:

Hi Sim.

That’s because if the row has a user ID, then the importer will try to update that user, it won’t try to create a new one. If the user doesn’t exist, it’ll give that error in the screenshot.

If you want to create the user, then the email address should not be in use, has to be unique (same for username).

I hope that helps. :slight_smile:

1 Like

Oh no. The point wasn’t to create a new user, but to set EOT for a few existing ones (or update any other information if necessary).

The screenshot above shows the successful processing (non advanced). The problem is with the advanced import, which is not working to update existing users.

I left the comparison to help people who might face the issue and, also, to let you know the advanced import isn’t updating existing users and giving that error message instead.

I see.

When you exported it, did you use the format for re-importation?

Could you show me here what your first line of the CSV file is? (redacting any private info) The line that you get the error/warning for.

Thanks :slight_smile:

1 Like

Thanks for your message!

I regenerated the file, since I overwrote it with the old format when I did the entire thing again, keeping only one line for your reference.

This was my procedure (the one that caused the error):

  1. Advanced Export/Import On (from start until the end);

  2. Exported all users with UTF-8 Flag ON (format ready for reimport);

  3. On Microsoft Excel, filtered and removed all lines for users I did NOT want to change (kept the top line which has the headers, of course, unchanged);

  4. Added EOT using UNIX format (like I saw you used for this file format) at the assigned EOT column;

  5. Saved the File (I redacted the attachment): export-1-10.zip (1.7 KB)

  6. Tried to Import the file and got the error.

I wish it’s helpful :innocent:

Meanwhile I am perfectly OK using the non advanced export/import :wink:

1 Like