(UPDATE: After testing this only happens in Chrome. Works fine in Firefox. Any ideas?)

All downloads are corrupted. Can’t open PDFs, ZIPs, DOCs when downloaded. File size between original and download is slightly different. What is going on? This worked fine for years, no changes here. Tried changing theme to see if that was a problem no luck there.

a href="[s2File download=‘my-file.pdf’ download_key=‘true’ /]">Download Here</a

(intentionally left off leading < and > or it forms a link here)

Are they downloading from a secure site? I know Chrome blocks downloads now if the source is not secure.

Are all of your members having the same issue with Chrome or just you?

Yes, site is secure. All my members are having the issue…at least the ones I heard from. They reported it to me and I replicated it in Chrome. When I use Firefox it’s all good.

By the way, not working in Microsoft Edge either. The files when downloads are a larger than the origiinal files.

I am going to need support here. I disabled all plugins. Again, downloads are not working unless using Firefox.

Appears to be resolved. A plugin moved gZip exclusions further down in htaccess file. When i moved it to the top it worked again.

Great to hear you figured it out. Thanks for sharing the solution. We seem to be pretty much on our own here with this plugin.

You’re right. It’s very concerning as this plugin is vital to our business.

I’m in the same boat. I’m sure lots of people are. If s2Member suddenly stops working, I don’t know what I will do.