Ajax-loader.gif loading over HTTP instead of HTTPS

Hi

I am getting a mixed content error on my www.hiberniacollege.com.

“Mixed Content: The page at ‘https://hiberniacollege.com/’ was loaded over HTTPS, but requested an insecure image ‘http://hiberniacollege.com/wp-content/plugins/s2member/src/images/ajax-loader.gif’. This content should also be served over HTTPS.”

I am using WPEngine.

One response recommends ensuring that the following setting is set to no. “Okay, the solution here was a setting in s2Member under general options -> login welcome page -> Alway redirect non-admin users using http?”

However I do not have this setting? I am using the Pro version ’ s2Member Pro v170722’.

Does anyone have a solution to fix this?

J

That setting was removed so as to avoid causing this problem.

You say you’re with WPEngine. They are known for having very aggressive caching, and caching could certainly cause this. I think you need to talk to them.

I’m having the same problem and on WPengine with the latest pro version.

thanks

Me too. Same issue at WP Engine.

If you force ssl with s2Member, do you still get that?

Create a custom field for s2member_force_ssl set to yes on that page.

If you’re using Gutenberg, go to the editor Options and enable Custom Fields from there first, then you’ll find the Custom Fields at the bottom of the page. https://www.namehero.com/startup/how-to-use-custom-fields-in-gutenberg-screenshots-example/

If that doesn’t do it, I’d troubleshoot testing for plugin or theme conflict. https://s2member.com/kb-article/common-troubleshooting-tips/

This plugin may help test that without affecting the site users: https://wordpress.org/plugins/health-check/

Let me know how it goes. :slight_smile:

I did that and it didn’t work. Just 1 file that’s http and no way to fix it. I’m forcing SSL on cloudflare it’s usually pretty strict. URL is https://globalintelhub.com https://globalintelhub.com/wp-content/plugins/s2member/src/images/ajax-loader.gif really want a fix for this.

Hi crediblock.

I can’t reproduce that on my site…

I found your page with the pro-form at https://globalintelhub.com/signup/

Because the s2member_force_ssl is shown in the pro-form, it seems you added it as a custom profile field from s2’s General Options.

Screenshot_2020-09-16%20Signup%20to%20Global%20Intel%20Hub

That would not be correct. The s2member_force_ssl goes in the WordPress page itself, as a custom field of the page, in the page editor.

Screenshot_2020-09-16%20Edit%20Page%20%E2%80%B9%20s2Member%20Membership%20Plugin%20for%20WordPress%20%E2%80%94%20WordPress

I hope that helps. :slight_smile: