Access link = User registration is currently not allowed

Hi, I know this topic exists but I suspect a unique situation. The Registration Access Link Generator won’t allow new users to register. I am adding a Paid Subscriber ID and Custom Capability. The user gets the “User registration is currently not allowed.” message on the registration screen.

It’s also not working when they pay via PayPal - which we are double checking API settings. Because it’s not working with the link generator, I feel like it may not be a PayPal issue… but who knows. I hate PayPal but the client insists!

Thanks for any thoughts you may have.

If you are using PayPal buttons, they stopped working on the weekend. See Buttons Stopped Working - DEPRECATED_PARAM_MODIFY

Thank you. Its helpful to know others are seeing what I am seeing.

Thank you, I did review the PARAM MODIFY discussion but I think it’s unrelated to the manual Access Link Generator not working. Since it doesn’t involve PayPal at all. It’s just a manual registration link I can send to customers. The link displays the “User registration is currently not allowed” message. I have tried using default WP themes and deactivated ALL plugins to test. I also contacted my host at Flywheel and they could not locate anything that would affect it.

This started Tuesday after I migrated the site to Flywheel.

FYI I also triple checked all the PayPal API settings just to make sure, but as I said, it does not even go to PayPal.

Any advice would be huge! Thank you.

**EDIT: I should mention the registration Access Link does work when I’m logged in as an Admin but the Custom Capabilities set with the Access Link Generator does are not included in the user profile.

This tool is payment gateway specific as per the “Paid Subsc ID”.

Your comment "the registration Access Link does work when I’m logged in as an Admin but the Custom Capabilities set with the Access Link Generator does are not included in the user profile." is interesting in that you say it works for admin but the CC is not added to the profile…which means it didn’t work. Can you elaborate as to what “worked”.

You also mentioned that it worked previously but stopped working when you moved to Flywheel is that correct?

Hi. Thanks for the reply.

When I am logged in as an admin, the registration links created under Dashboard >PayPal Buttons > Member Registration Access Links display the user registration form - but only when I am logged in.

However, when I am still logged in as Admin and complete the user registration form it adds me to the list of users, but the Custom Capability is not captured when I register. This of course should be part of the Registration Access Link.

I use my own subscriber IDs for these customers. Not from PayPal. Does that matter?

If I send that link to a customer or test it when I am NOT logged in it says “User registration is currently not allowed.”

Sending the Registration link to customers was working before we moved hosting providers.

Thank you!

CAVEAT: I don’t use this software so take my comments simply as suggestions.

The purpose of this tool appears to be to allow you to recreate the subscriber registration link that gets automatically produced when someone pays to subscribe to a service. With that in mind, the Paid Subscr. ID would appear to need to be set to the subscriber ID from the payment gateway for the user you want to create the link for.

With that in mind, your comments above form a puzzling set of contradictions

  • It worked before moving to Flywheel and now it doesn’t - the only thing moving a site would usually impact would be: change in php version, change in installed php modules, firewall configuration, permalinks, url misconfiguration (www vs. raw domain), switch from http to https
  • You do not appear to be using gateway Paid Subscr. ID so it should never have worked according to the documentation…so how did it “work” before!
  • The “User registration is currently not allowed” message comes from WordPress not the s2member plugin…why is it appearing! The purpose of executing the access link is to link a WordPress user account to a Paid subscription account in the gateway so the user account has to exist already…in your tests does the user account already exist? Does the subscription account in the gateway exist?

I’m not sure I can help you any further. I don’t know why this worked before and there are too many moving parts. I’ve pointed you in a few directions but that is all I can do here. Maybe another community member will be able to help you further. Good luck…hope you work it out.