Security Badge Has Disappeared

The s2Member Security Badge has disappeared from my pages upon loading. All of my settings indicate that it is in effect and I have done nothing to change it. What gives?

May be hidden by CSS?

I didn’t make any changes at all. How can I get it back? Reinstall?


Have you inspected your web page in the area near where the Security Badge should be displayed to see if the Badge has been hidden or displaced by CSS? Also view the page source to see if the code to display the Badge is there: it may have been moved outside the visible area of the viewport by other code.

If the code isn’t in the source, then obviously there is another issue.

I’m having the same problem. Although the website and badge is new and has never shown itself. I’ts been installed over 24 hours ago now.
I’ve tested all setting several times and I do get a ‘1’ upon testing.

<img src="//;" width="200" height="55" style="border:0; width:200px; height:55px;" alt="s2Member®" title="s2Member® (Security for WordPress®)" data-pin-nopin="true">

There is no css hiding the image.

There is no image at the image source, but security seems to be ok.

Any solution?

My badge doesn’t show when I view my website on PC, but DOES show when viewed on a mobile phone. What does this suggest?

Is that true of every browser, or just particular browsers?

Very good question - sorry, I should have thought to investigate that before posting.

Having tested a load of others, I find that badge DOES show in: Internet Explorer, Opera, Windows phone, Android.

Badge does NOT show in: Google Chrome (PC) - my default browser. I’ve checked on two other PCs and it’s the same, so I don’t think it’s because I’ve changed a browsing setting.

Showing in Opera but not in Chrome is interesting because they are largely the same under the hood.

You haven’t mentioned Firefox, but I think you need to follow the steps I set out here: Remove "Registration Options" Dropdown

I tried right-clicking on the empty area where the badge should be, and was quite surprised to find there is something hiding in there.

Tried to paste it here but I think the forum page is executing it, lol. How do I paste it so it shows up?

You need to put three backticks (i.e. ```) before it, hit Enter, then paste your code, hit Enter again, then add three more backticks.


<div class="ws-plugin--s2member-s-badge">
	<a href="" onclick="';', '_popup', 'width=770,height=720,left='+((screen.width/2)-(770/2))+',screenX='+((screen.width/2)-(770/2))+',top='+((screen.height/2)-(720/2))+',screenY='+((screen.height/2)-(720/2))+',location=0,menubar=0,toolbar=0,scrollbars=0,resizable=1'); return false;" title="s2Member®"><img src="//;" width="200" height="55" style="border:0; width:200px; height:55px;" alt="s2Member®" title="s2Member® (Security for WordPress®)"></a>

Attached screenshot in case that doesn’t work.

I can’t see a problem with it, and it’s working on both Firefox and Chrome for me.

Hmm… it’s a puzzle.

Would you mind taking a moment to check whether you can see the badge on my site? Maybe it is just me somehow!


Sorry that I evidently wasn’t clear. I meant that I looked at your site, and it was working on both Firefox and Chrome.

Thanks Tim. I guess it’s just something about my house, lol. Won’t worry about it if it’s just me. Thanks again.

Just FYI, I have a lot of sites where I have problems with Chrome not refreshing pages until I flush the DNS via the command line. (Windows: ipconfig /flushdns). It is quite annoying.

I too see your security badge in Chrome and Edge.

I am having the same issue. In my dashboard, the badge shows that its verified, and the site is secure. But it’s not showing up on my page. I’ve checked it on a couple of browsers and I still don’t see it. Could someone check and let me know if they see it? This is the page I have the shortcode on:

Yes. I see the security badge. Screenshot