Existing members can't purchase without creating a new account

Okay thanks Cristian. I’ll give that a try and report back my findings. In the meantime, anything noteworthy in mu-plugin.php?

I’ve had issues with every managed host I’ve tried getting along with s2 except for Kinsta. I’ve never tried WPengine, though.

s2 seems to be very picky about caching.

Thanks Ric…

I got thinking about the hosting issue as I have had caching problems with WP Engine in the past.

So as a test, I migrated my site to Flywheel. This didn’t resolve my issue. I deactivated all the plugins (except S2) and changed the theme…still didn’t resolve the problem.

So I think this rules out web hosting as the root of the problem.

(As an aside, what’s your take on Kinsta? Happy with them?)

Before I go to the effort of manually adding plugins back in as Christian suggests, is it possible to narrow down what might be the problem? For instance…

  • Javascript (but I think we ruled that out?)

  • something in functions.php?

  • mu-plugins (did we rule that out?)

  • something else?


If you remove every other plugin and you still have the behavior, then you don’t need to add them back some at a time and test after each, because they don’t seem to be what’s causing the issue.

You still have the issue, so it’s something else that’s still there having an effect. Although I don’t see as many errors in the console, the pro-form’s JS is not working, so something’s affecting it.

I would check the must-use plugins, move those to another folder, leave the /wp-content/mu-plugins/ folder empty, and test again.

Change the theme to the default one, and test again.

Let me know how it goes with those tests, please. :slight_smile:

I had caching problems with Flywheel too (if you search here for “Flywheel” you’ll see :)).

Kinsta seems great so far. It’s literally the first WP managed host with aggressive caching that I’ve tried that works with s2.

Oh, and WP-Engine == Flywheel now.